WP Engine Offers All Customers Extended Support for PHP 7.4 


On November 28, the community-supported version of PHP 7.4 will reach End of Life (EOL) status, meaning the team of PHP developers who regularly maintain the coding language in stable version releases will no longer provide bug fixes, security patches, or critical security updates.

While that’s par for the course when it comes to PHP—currently each PHP version is supported for two years after its initial release and fully deprecated after three—the PHP 7.4 EOL is unique in that WordPress, along with a wide range of themes and plugins, are not yet fully compatible with newer PHP versions (8.0+).

How to Check Which Version of PHP You’re Using

Extended Support for WP Engine and Flywheel Customers 

While we prefer that all of our customers upgrade to the latest versions of WordPress and PHP,  we also understand that doing so right now could lead to critical errors on their websites.  

That’s the last thing we want, but at the same time, WP Engine has always worked hard to prevent our customers from using unsupported versions of PHP (or any other software for that matter) as it can open up their sites, and our platform, to security risks. 

With that in mind, WP Engine has invested in ongoing security support for PHP 7.4. This will allow all of our customers—across WP Engine and Flywheel—to stay on PHP 7.4 past the November 28 EOL date, while still keeping their sites and our platform secure. It’s also currently the only such offering for extended PHP 7.4 support by a managed platform provider. 

While we haven’t yet determined a new deadline for customers to stop using PHP 7.4, we believe additional time will afford them, the wider WordPress community, and individual plugin and theme developers with the window they need to resolve open incompatibilities.

As a managed provider that’s deeply involved with the WordPress community, we understand the current pain points surrounding PHP 8.0 compatibility and view this as an opportunity to provide our customers with a much-needed service—extended security support. With that in mind, WP Engine will not require customers to upgrade from PHP 7.4 to PHP 8.0 on the EOL date, November 28th, 2022.

If you have any questions, please reach out to our Support teams via the WP Engine User Portal, the Flywheel App, or any of the options listed here


Are You Ready to Update to PHP 8.0? 

While compatibility issues are indeed something you should be aware of, WP Engine customers are fully able to make the update to PHP 8.0, if they wish to do so. 

Regardless of known compatibility issues, WP Engine always recommends that site updates be conducted in a staging or development environment to ensure your live site stays safe. This will also give you the option to test for compatibility issues before pushing your updated site live. 

Performing the update on your own is a simple process—just log in to your user portal and follow the steps provided here. If you still have questions you can login to your account to contact support. 


What Are the Benefits of PHP 8.0?

There are a number of improvements and new features that come with PHP 8.0, including: 

While in general, running an up-to-date version of PHP will speed up your site (the upgrade to 7.4 last year saw a significant speed increase across our customers’ sites) it also prevents bad actors from taking advantage of security vulnerabilities that could be lurking in older PHP versions—a major factor in our decision to invest in extended PHP 7.4 support.  


Keeping Your WordPress Sites—and Your PHP Version—Safe From Vulnerabilities

With WP Engine’s extended support for PHP 7.4, customers need not worry about vulnerabilities in that version (and no current vulnerabilities have been flagged). 

That said, all WP Engine and Flywheel customers are currently using PHP 7.4, 8.0, or higher, and making the jump (or preparing to make the jump) to 8.0 from older versions of PHP is something you should begin to consider.

You can take a closer look at PHP compatibility with specific WordPress versions here as well as a list of remaining deprecation notices (related to incompatibility) in WordPress 5.9 here.

Want to find out more? Speak to a WP Engine WordPress expert today, or check out our PHP Version and Upgrade Guide for more detail.

We will be happy to hear your thoughts

Leave a reply

some deals vip
Logo
Enable registration in settings - general
Compare items
  • Total (0)
Compare
0
Shopping cart